Skip to content
Sections
>> Trisquel >> Pakete >> ecne (12.0LTS) >> python >> python3-aioquic
[  ecne  ] [  ecne-updates  ] [  xolotl  ]
[ Quellcode: aioquic  ]

Paket: python3-aioquic (0.9.25-3build2)

Python implementation of QUIC and HTTP/3

Library for the QUIC network protocol in Python. It features a minimal TLS 1.3 implementation, a QUIC stack and an HTTP/3 stack.

QUIC was standardised in `RFC 9000`_ and HTTP/3 in `RFC 9114`_. ``aioquic`` is regularly tested for interoperability against other `QUIC implementations`_.

Features --------

  - QUIC stack conforming with `RFC 9000`_
  - HTTP/3 stack conforming with `RFC 9114`_
  - minimal TLS 1.3 implementation conforming with `RFC 8446`_
  - IPv4 and IPv6 support
  - connection migration and NAT rebinding
  - logging TLS traffic secrets
  - logging QUIC events in QLOG format
  - HTTP/3 server push support

Andere Pakete mit Bezug zu python3-aioquic

  • hängt ab von
  • empfiehlt
  • schlägt vor
  • dep: libc6 (>= 2.14) [amd64]
    GNU C Library: Shared libraries
    auch ein virtuelles Paket, bereitgestellt durch libc6-udeb
    dep: libc6 (>= 2.17) [arm64, ppc64el]
    dep: libc6 (>= 2.27) [riscv64]
    dep: libc6 (>= 2.4) [armhf]
  • dep: libssl3t64 (>= 3.0.0)
    Secure Sockets Layer toolkit - shared libraries
  • dep: python3
    interactive high-level object-oriented language (default python3 version)
    dep: python3 (>= 3~)
  • dep: python3-certifi
    root certificates for validating SSL certs and verifying TLS hosts (python3)
  • dep: python3-cryptography
    Python library exposing cryptographic recipes and primitives (Python 3)
  • dep: python3-openssl
    Python 3 wrapper around the OpenSSL library
  • dep: python3-pylsqpack
    Python wrapper for the ls-qpack QPACK library
  • dep: python3-service-identity (>= 24.1.0)
    Service identity verification for pyOpenSSL (Python 3 module)

python3-aioquic herunterladen

Download für alle verfügbaren Architekturen
Architektur Paketgröße Größe (installiert) Dateien
amd64 73,3 kB467 kB [Liste der Dateien]
arm64 72,9 kB558 kB [Liste der Dateien]
armhf 72,1 kB444 kB [Liste der Dateien]
ppc64el 73,4 kB558 kB [Liste der Dateien]
riscv64 73,3 kB454 kB [Liste der Dateien]