Package: python3-aioquic (0.9.25-3)
Links for python3-aioquic
Trisquel Resources:
Download Source Package aioquic:
Maintainer:
Original Maintainers:
- Debian Python Team
- Scott Kitterman
External Resources:
- Homepage [github.com]
Similar packages:
Python implementation of QUIC and HTTP/3
Library for the QUIC network protocol in Python. It features a minimal TLS 1.3 implementation, a QUIC stack and an HTTP/3 stack.
QUIC was standardised in `RFC 9000`_ and HTTP/3 in `RFC 9114`_. ``aioquic`` is regularly tested for interoperability against other `QUIC implementations`_.
Features --------
- QUIC stack conforming with `RFC 9000`_ - HTTP/3 stack conforming with `RFC 9114`_ - minimal TLS 1.3 implementation conforming with `RFC 8446`_ - IPv4 and IPv6 support - connection migration and NAT rebinding - logging TLS traffic secrets - logging QUIC events in QLOG format - HTTP/3 server push support
Other Packages Related to python3-aioquic
|
|
|
-
- dep: libc6 (>= 2.14)
- GNU C Library: Shared libraries
also a virtual package provided by libc6-udeb
-
- dep: libssl3 (>= 3.0.0)
- Package not available
-
- dep: python3
- interactive high-level object-oriented language (default python3 version)
- dep: python3 (>= 3~)
-
- dep: python3-certifi
- root certificates for validating SSL certs and verifying TLS hosts (python3)
-
- dep: python3-cryptography
- Python library exposing cryptographic recipes and primitives (Python 3)
-
- dep: python3-openssl
- Python 3 wrapper around the OpenSSL library
-
- dep: python3-pylsqpack
- Python wrapper for the ls-qpack QPACK library
-
- dep: python3-service-identity (>= 24.1.0)
- Service identity verification for pyOpenSSL (Python 3 module)
-
- sug: python-aioquic-doc
- documentation for the aioquic Python library
Download python3-aioquic
| Architecture | Package Size | Installed Size | Files |
|---|---|---|---|
| amd64 | 73.1 kB | 467 kB | [list of files] |