Package: libldaptive-java-doc (2.1.1+ds-1)
Links for libldaptive-java-doc
Trisquel Resources:
Download Source Package ldaptive:
Maintainer:
Original Maintainers:
- Debian Java Maintainers (Mail Archive)
- Joseph Nahmias
External Resources:
- Homepage [www.ldaptive.org]
Similar packages:
simple, extensible Java API for interacting with LDAP servers - documentation
Ldaptive is a simple, extensible Java API for interacting with LDAP servers. It was designed to provide easy LDAP integration for application developers. Features include:
* Netty based asynchronous networking
* Reactive API
* Connection pooling
* Authentication API with support for password policy
* JAAS modules for authentication and authorization
* SSL/startTLS support with easy configuration of trust and key material
* Input/output of LDIF
* Supported controls:
* Authorization Identity (RFC 3829)
* Content Synchronization (RFC 4533)
* Entry Change Notification (draft-ietf-ldapext-psearch-03)
* ManageDsaIT (RFC 3296)
* Matched Values (RFC 3876)
* Paged Results (RFC 2696)
* Password Policy (draft-behera-ldap-password-policy-10 and
draft-vchu-ldap-pwd-policy-00)
* Persistent Search (draft-ietf-ldapext-psearch-03)
* Proxy Authorization (RFC 4370)
* Server Side Sorting (RFC 2891)
* Session Tracking (draft-wahl-ldap-session-03)
* Tree Delete (draft-armijo-ldap-treedelete)
* Virtual List View (draft-ietf-ldapext-ldapv3-vlv-09)
This package contains the API documentation for libldaptive-java.
Other Packages Related to libldaptive-java-doc
|
|
|
-
- rec: default-jdk-doc
- Standard Java or Java compatible Development Kit (documentation)
-
- sug: libldaptive-java
- simple, extensible Java API for interacting with LDAP servers
Download libldaptive-java-doc
| Architecture | Package Size | Installed Size | Files |
|---|---|---|---|
| all | 765.0 kB | 27281 kB | [list of files] |