Paket: python3-aioquic (0.9.25-3build2)
Länkar för python3-aioquic
Trisquelresurser:
Hämta källkodspaketet aioquic:
Ansvarig:
Original Maintainers:
- Debian Python Team
- Scott Kitterman
Externa resurser:
- Hemsida [github.com]
Liknande paket:
Python implementation of QUIC and HTTP/3
Library for the QUIC network protocol in Python. It features a minimal TLS 1.3 implementation, a QUIC stack and an HTTP/3 stack.
QUIC was standardised in `RFC 9000`_ and HTTP/3 in `RFC 9114`_. ``aioquic`` is regularly tested for interoperability against other `QUIC implementations`_.
Features --------
- QUIC stack conforming with `RFC 9000`_ - HTTP/3 stack conforming with `RFC 9114`_ - minimal TLS 1.3 implementation conforming with `RFC 8446`_ - IPv4 and IPv6 support - connection migration and NAT rebinding - logging TLS traffic secrets - logging QUIC events in QLOG format - HTTP/3 server push support
Andra paket besläktade med python3-aioquic
|
|
|
-
- dep: libc6 (>= 2.14) [amd64]
- GNU C Library: Shared libraries
också ett virtuellt paket som tillhandahålls av libc6-udeb
- dep: libc6 (>= 2.17) [arm64, ppc64el]
- dep: libc6 (>= 2.27) [riscv64]
- dep: libc6 (>= 2.4) [armhf]
-
- dep: libssl3t64 (>= 3.0.0)
- Secure Sockets Layer toolkit - shared libraries
-
- dep: python3
- interactive high-level object-oriented language (default python3 version)
- dep: python3 (>= 3~)
-
- dep: python3-certifi
- root certificates for validating SSL certs and verifying TLS hosts (python3)
-
- dep: python3-cryptography
- Python library exposing cryptographic recipes and primitives (Python 3)
-
- dep: python3-openssl
- Python 3 wrapper around the OpenSSL library
-
- dep: python3-pylsqpack
- Python wrapper for the ls-qpack QPACK library
-
- dep: python3-service-identity (>= 24.1.0)
- Service identity verification for pyOpenSSL (Python 3 module)
-
- sug: python-aioquic-doc
- documentation for the aioquic Python library
Hämta python3-aioquic
| Arkitektur | Paketstorlek | Installerad storlek | Filer |
|---|---|---|---|
| amd64 | 73,3 kbyte | 467 kbyte | [filförteckning] |
| arm64 | 72,9 kbyte | 558 kbyte | [filförteckning] |
| armhf | 72,1 kbyte | 444 kbyte | [filförteckning] |
| ppc64el | 73,4 kbyte | 558 kbyte | [filförteckning] |
| riscv64 | 73,3 kbyte | 454 kbyte | [filförteckning] |