Skip to content
Sections
>> Trisquel >> Packages >> ecne (12.0LTS) >> python >> python3-aioquic
[  ecne  ] [  ecne-updates  ] [  xolotl  ]
[ Source: aioquic  ]

Пакунок: python3-aioquic (0.9.25-3build2)

Python implementation of QUIC and HTTP/3

Library for the QUIC network protocol in Python. It features a minimal TLS 1.3 implementation, a QUIC stack and an HTTP/3 stack.

QUIC was standardised in `RFC 9000`_ and HTTP/3 in `RFC 9114`_. ``aioquic`` is regularly tested for interoperability against other `QUIC implementations`_.

Features --------

  - QUIC stack conforming with `RFC 9000`_
  - HTTP/3 stack conforming with `RFC 9114`_
  - minimal TLS 1.3 implementation conforming with `RFC 8446`_
  - IPv4 and IPv6 support
  - connection migration and NAT rebinding
  - logging TLS traffic secrets
  - logging QUIC events in QLOG format
  - HTTP/3 server push support

Інші пакунки пов'язані з python3-aioquic

  • depends
  • recommends
  • suggests
  • dep: libc6 (>= 2.14) [amd64]
    GNU C Library: Shared libraries
    also a virtual package provided by libc6-udeb
    dep: libc6 (>= 2.17) [arm64, ppc64el]
    dep: libc6 (>= 2.27) [riscv64]
    dep: libc6 (>= 2.4) [armhf]
  • dep: libssl3t64 (>= 3.0.0)
    Secure Sockets Layer toolkit - shared libraries
  • dep: python3
    interactive high-level object-oriented language (default python3 version)
    dep: python3 (>= 3~)
  • dep: python3-certifi
    root certificates for validating SSL certs and verifying TLS hosts (python3)
  • dep: python3-cryptography
    Python library exposing cryptographic recipes and primitives (Python 3)
  • dep: python3-openssl
    Python 3 wrapper around the OpenSSL library
  • dep: python3-pylsqpack
    Python wrapper for the ls-qpack QPACK library
  • dep: python3-service-identity (>= 24.1.0)
    Service identity verification for pyOpenSSL (Python 3 module)

Завантажити python3-aioquic

Завантаження для всіх доступних архітектур
Архітектура Розмір пакунка Розмір після встановлення Файли
amd64 73.3 kB467 kB [список файлів]
arm64 72.9 kB558 kB [список файлів]
armhf 72.1 kB444 kB [список файлів]
ppc64el 73.4 kB558 kB [список файлів]
riscv64 73.3 kB454 kB [список файлів]