Skip to content
Sections
>> Trisquel >> Packages >> xolotl (13.0) >> python >> python3-joserfc
[  xolotl  ]
[ Source: joserfc  ]

Package: python3-joserfc (1.6.2-1)

Python library for JSON Object Signing and Encryption (JOSE)

The library provides a comprehensive implementation of several essential JSON Object Signing and Encryption (JOSE) standards. It includes implementations of JSON Web Signature (JWS), JSON Web Encryption (JWE), JSON Web Key (JWK), JSON Web Algorithms (JWA), and JSON Web Token (JWT). The module follows various Request for Comments (RFCs) standards such as RFC7515, RFC7516, RFC7517, RFC7518, RFC7519, and others. Additionally, it supports draft RFC implementations like C20P, XC20P, and the Elliptic Curve Diffie-Hellman One- Pass Unified Model. The extensible API allows for advanced cryptographic operations and secure data transmission.

Other Packages Related to python3-joserfc

  • depends
  • recommends
  • suggests
  • dep: python3
    interactive high-level object-oriented language (default python3 version)
  • dep: python3-cryptography (>= 45.0.1)
    Python library exposing cryptographic recipes and primitives

Download python3-joserfc

Download for all available architectures
Architecture Package Size Installed Size Files
all 43.1 kB266 kB [list of files]