Skip to content
Sections
>> Trisquel >> 套件 >> nabia-security >> admin >> flatpak
aramo  ] [  nabia  ] [  etiona  ] [  etiona-security  ] [  nabia-security  ] [  etiona-updates  ] [  nabia-updates  ]
[ 原始碼: flatpak  ]

套件: flatpak (1.6.5-0ubuntu0.4)

Application deployment framework for desktop apps

Flatpak installs, manages and runs sandboxed desktop application bundles. Application bundles run partially isolated from the wider system, using containerization techniques such as namespaces to prevent direct access to system resources. Resources from outside the sandbox can be accessed via "portal" services, which are responsible for access control; for example, the Documents portal displays an "Open" dialog outside the sandbox, then allows the application to access only the selected file.

Each application uses a specified "runtime", or set of libraries, which is available as /usr inside its sandbox. This can be used to run application bundles with multiple, potentially incompatible sets of dependencies within the same desktop environment.

This package contains the services and executables needed to install and launch sandboxed applications, and the portal services needed to provide limited access to resources outside the sandbox.

其他與 flatpak 有關的套件

  • 依賴
  • 推薦
  • 建議
  • dep: adduser
    套件暫時不可用
  • dep: bubblewrap (>= 0.4.0)
    套件暫時不可用
  • dep: libappstream-glib8 (>= 0.6.1)
    套件暫時不可用
  • dep: libarchive13 (>= 3.0.4)
    Multi-format archive and compression library (shared library)
  • dep: libc6 (>= 2.28)
    GNU C Library: Shared libraries
    同時作為一個虛擬套件由這些套件提供: libc6-udeb
  • dep: libdconf1 (>= 0.26.0)
    套件暫時不可用
  • dep: libfuse2 (>= 2.9.2)
    套件暫時不可用
  • dep: libgdk-pixbuf2.0-0 (>= 2.22.0)
    GDK Pixbuf library
  • dep: libglib2.0-0 (>= 2.57.2)
    GLib library of C routines
  • dep: libgpgme11 (>= 1.1.8)
    套件暫時不可用
  • dep: libjson-glib-1.0-0 (>= 1.2.0)
    套件暫時不可用
  • dep: libostree-1-1 (>= 2019.6)
    套件暫時不可用
  • dep: libpolkit-agent-1-0 (>= 0.105)
    PolicyKit Authentication Agent API
  • dep: libpolkit-gobject-1-0 (>= 0.101)
    PolicyKit Authorization API
  • dep: libseccomp2 (>= 2.5.1)
    high level interface to Linux seccomp filter
  • dep: libsoup2.4-1 (>= 2.41.90)
    套件暫時不可用
  • dep: libsystemd0
    systemd utility library
  • dep: libxau6
    套件暫時不可用
  • dep: libxml2 (>= 2.7.4)
    GNOME XML library
  • dep: xdg-dbus-proxy (>= 0.1.0)
    套件暫時不可用
  • rec: desktop-file-utils
    套件暫時不可用
  • rec: gtk-update-icon-cache
    套件暫時不可用
  • rec: hicolor-icon-theme
    套件暫時不可用
  • rec: libpam-systemd
    system and service manager - PAM module
  • rec: p11-kit
    p11-glue utilities
  • rec: policykit-1
    framework for managing administrative policies and privileges
  • rec: shared-mime-info
    套件暫時不可用
  • rec: xdg-desktop-portal (>= 1.6)
    套件暫時不可用
  • rec: xdg-desktop-portal-gtk (>= 1.6)
    套件暫時不可用
    或者 xdg-desktop-portal-backend
    套件暫時不可用

下載 flatpak

下載可用於所有硬體架構的
硬體架構 套件大小 安裝後大小 檔案
amd64 1,044.0 kB5591 kB [文件列表]
armhf 923.6 kB4058 kB [文件列表]